[Timezone Detection]
Create Account - Join in Seconds!

User Name: Email Address:
Human Verification

What type of fish is in the middle of CaptiveReefs (top left corner of page...hint it is the main character in Finding Nemo) )

Trying to get Bubble Magus nac5e hob skimmer to work?


Bookmark and Share
Results 1 to 8 of 8
  1. #1
    CR Member
    Join Date
    Apr 2012
    Location
    Howell Michigan
    Posts
    47

    Default Trying to get Bubble Magus nac5e hob skimmer to work?

    Hello, just setting up my first sw tank a 72 gal bowfront, finally got it filled with water and decided before turning in for the night would check to see if the skimmer worked. The skimmer I have is a bubble magus nac5e. I will applogize now for any terminalogy on the skimmer parts that I may describe wrong, and also sorry for any sp mistakes getting late and brain is getting somewhat fuzzy. From the information that I have been able to find I know that I need to prime the pump, I added saltwater into the cylindar body of the skimmer enough to cover the pvc elbow on the piece that runs from the pump into the body of the skimmer. I closed the air line valve completly and on the other side where the water leaves the skimmer I turned the pvc adjustment so that was closed. Plugged in the skimmer and all I get is a humming sound from the pump. I can feel it running and produced a little heat. Did not leave it plugged in for too long because if I am doing something wrong I don't want to burn out the pump. Any ideas of what I may be doing wrong or what I need to do to get this going? Or is it that my pump is not working properly, hoping that this is not the case. I had gotten the skimmer from a local reefer, so it is not like I can contact the company to have it replaced under warrranty. If needed I can post some pictures of the skimmer and the way that I have it set up tomorrow. Thanks

  2. #2
    binford4000 - Reefkeeper
    Join Date
    Feb 2011
    Location
    farmington hills mi
    Posts
    1,798
    First Name
    Old man
    Awards Tank of the Month - May 2012 Tank of the Month

    Default

    Sounds allot like the impeller is shot. There fairly cheap tho and easy to change. Good luck getting other then it worked fine for me out of the seller. What pump does it have ? I have a box of pumps I don't use. Lmk know I might have one ya can have

  3. #3
    Tropical Buff - Reefkeeper CR Member
    Join Date
    Dec 2011
    Location
    Pinckney MI
    Posts
    440
    First Name
    Bart

    Default

    Remove the skimmer from the tank, then remove the pump from the skimmer. Take the skimmer pump apart and make sure the internals are clean and that the impeller is spinning free. Re-assemble and test run it in a sink or bucket. If it seems to be functioning ok re-assemble the skimmer and test again before placing the unit back on the tank. Hopefully this helps

  4. #4
    CR Member
    Join Date
    Apr 2012
    Location
    Howell Michigan
    Posts
    47

    Default

    Thanks everyone, have got it running now. Took it apart pulled the impellar out made sure all was clean and placed impellar back in. Made sure it would move and reassemble. The pump sits on the outside of the tank so was unsure about placing it in bucket or sink. Set everything back up and tried running it again with success.

    binford the pump is an Altman 2000. I am thinking about looking into getting a spare impellar so that way if this one does go out on me I will have a replacement on hand.

  5. #5
    creefer - Reefkeeper CR Member
    Join Date
    Feb 2010
    Location
    48116
    Posts
    786
    First Name
    Chris

    Default

    Quote Originally Posted by BarbH View Post
    Thanks everyone, have got it running now. Took it apart pulled the impellar out made sure all was clean and placed impellar back in. Made sure it would move and reassemble. The pump sits on the outside of the tank so was unsure about placing it in bucket or sink. Set everything back up and tried running it again with success.

    binford the pump is an Altman 2000. I am thinking about looking into getting a spare impellar so that way if this one does go out on me I will have a replacement on hand.
    Glad to hear you got it working, Barb!

  6. #6
    CR Member
    Join Date
    Apr 2012
    Location
    Howell Michigan
    Posts
    47

    Default

    Quote Originally Posted by creefer View Post
    Glad to hear you got it working, Barb!
    Thanks Chris, was happy to get it going myself. Not sure if I have it adjusted right, will be posting later this evening with some pictures to check and see if I need to adjust anything right now.

  7. #7
    dlhirst - Reefkeeper
    Join Date
    Nov 2009
    Location
    Detroit MI
    Posts
    607
    First Name
    Don

    Default

    Barb, if this is a protein skimmer, and you have no livestock in your tank yet (as other posts suggest), there really can't be a reason to run the skimmer just yet. I guess, perhaps, just to know that it runs. But, until you have some organic waste in the tank, there is nothing for the skimmer to skim. As long as you understand that, and you're not looking for anything to collect in the cup. I only know this because I was frustrated trying to get my skimmer to work in a brand new tank just a couple short years ago...

  8. #8
    CR Member
    Join Date
    Apr 2012
    Location
    Howell Michigan
    Posts
    47

    Default

    Quote Originally Posted by dlhirst View Post
    Barb, if this is a protein skimmer, and you have no livestock in your tank yet (as other posts suggest), there really can't be a reason to run the skimmer just yet. I guess, perhaps, just to know that it runs. But, until you have some organic waste in the tank, there is nothing for the skimmer to skim. As long as you understand that, and you're not looking for anything to collect in the cup. I only know this because I was frustrated trying to get my skimmer to work in a brand new tank just a couple short years ago...
    Thanks Don. Have had others suggest to let the skimmer run during the cycle to let it break in. Think will give it some time before running it, although still will need to figure out how to get it set properly. Know that I proabably will not pull a lot of stuff right away, although for awhile I do think that it was pulling stuff out.

Similar Topics

  1. Reef Octo, Bubble Magus and ice caps
    By jakem in forum Equipment Sales & Trades
    Replies: 2
    Last Post: 02-07-2013, 09:47 PM
  2. ATI Bubble Master 200 Skimmer-$100
    By Fishgeek88 in forum Equipment Sales & Trades
    Replies: 3
    Last Post: 06-26-2012, 06:35 PM
  3. 2x mp40s, reefkeeper, bubble magus doser
    By EMUreef in forum Equipment Sales & Trades
    Replies: 2
    Last Post: 06-21-2012, 01:29 PM
  4. Bubble Magus Triple Doser
    By wolverine57 in forum Equipment Sales & Trades
    Replies: 0
    Last Post: 09-10-2011, 10:14 PM
  5. Bak Pak2 protein skimmer with skimmer box / bubble trap NEW
    By ztoom in forum Equipment Sales & Trades
    Replies: 1
    Last Post: 05-31-2005, 06:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

About CaptiveReefs

    If you are interested in learning about reefkeeping or have a problem with your reef, our reefkeeping community is here to help. Feel free to ask a question or search our site. We have lots of experienced reefkeepers that are willing to provide free reefkeeping advice!

    Besides being a great resource for all levels of reef aquarium hobbyists, CaptiveReefs is a social experience that will enhance your enjoyment of reefkeeping. CaptiveReefs is committed to connecting reefkeepers with the support and information they need to grow beautiful coral reef aquariums.

Information

Connect with Us